Categories > OpenTBS with XLSX >

Excel could not open file - unreadable content

The forum is closed. Please use Stack Overflow for submitting new questions. Use tags: tinybutstrong , opentbs
By: Owen
Date: 2017-03-11
Time: 00:30

Excel could not open file - unreadable content


I have a spreadsheet template with 3 worksheets, 1 = manual input values (no data merge), 2 = merged data rows, 3 = results of individual VLOOKUP functions. It is always unreadable and requires Open & Repair after merge.

There are no explicit cell number references in the VLOOKUP function (other than for input value), and I've added a row of static data before the merged rows so that the function should always access valid data both before and after the merge with the current input value, but still no luck. 

The function looks like:

also tried:

After Open & Repair it works fine.

I updated to the latest OpenTBS version (1.9.8) but still no luck.

Any suggestions?

By: Skrol29
Date: 2017-03-12
Time: 00:27

Re: Excel could not open file - unreadable content

Hi Owen,

I cannot reproduce your bug.
Can you send you template and the result ?

Please note that the result of the formula won't be refreshed in the result of the merge.
A trick is to simply load the sheet with OpenTBS, then formula's cached results will be deleted.
  $TBS->PlugIn(OPENTBS_SELECT_SHEET, 'results');
By: Owen
Date: 2017-03-12
Time: 09:44

Re: Excel could not open file - unreadable content

Thanks Skrol,

I have sent you the template and merged result.
By: Skrol29
Date: 2017-03-13
Time: 22:21

Re: Excel could not open file - unreadable content


The "Merged.xlsx" file is corrupted because they are some extra data after the end of the zip file.

This is probably because your PHP script does send some content after the file is merged.

You extra data is: "File [xxxxxxx.xlsx] has been created."